ℹ️
Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
Comments errors
  • Hello again: I´m having problems when adding comments. If I login as admin and try to comment, I recive the following message: Deprecated: Assigning the return value of new by reference is deprecated in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 218 Warning: Cannot modify header information - headers already sent by (output started at C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php:218) in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 160 But when reload the page, the comments are there. As you say in others posts of the forum, I had to modify defaults.tpl to disable the error handler. I did it, and works well. But when I try to comment as an normal user, not admin, I can´t post anything. I fill all fields, but nothing happens, the page reload but continue without any comments. If I re-enable the error handler: Deprecated: Assigning the return value of new by reference is deprecated in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 218 Warning: Cannot modify header information - headers already sent by (output started at C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php:218) in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 160 Warning: Cannot modify header information - headers already sent by (output started at C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php:218) in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 168 Warning: Cannot modify header information - headers already sent by (output started at C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php:218) in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\comments.php on line 175 Warning: Parameter 1 to plugin_qspam_validate() expected to be a reference, value given in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\fp-includes\core\core.wp-plugin-interface.php on line 54 I tried others solutions found in the forums, like adding .htaccess or disabling the antyspam plugin, but did not work. Any idea? FlaPress version: 0.909.1 Thanks!
  • You are using PHP 5.3. You can disable E_DEPRECATED on the php_ini or with ini_set function. Or easily you can open comments.php, go to line 218 and remove the &. $q =& new FPDB_Query(array('id'=>$fp_params['entry'],'fullparse'=>false), null); That you have to change in $q =new FPDB_Query(array('id'=>$fp_params['entry'],'fullparse'=>false), null);
  • Thanks. I changed the comments.php, but did not work. Now, I recive only one error message: Warning: Parameter 1 to plugin_qspam_validate() expected to be a reference, value given in C:\Archivos de programa\xampp\xampp\htdocs\flatpress\fp-includes\core\core.wp-plugin-interface.php on line 54 But the comments refuse to work. Any other idea?
  • Disabling plugin qspam or editing on line 54 and add & before $the_args but I'm not shure. I could try but not now.
  • Yeeeees!! Disabling QuickSpamFilter solved the problem. Thanks.
This discussion has been closed.
All Discussions
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion