ℹ️
Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
immagine nella colonna widget destra
  • mi spegate come gaccio ad inserire una immagine nella colonna widget destra?
  • scrivi una nuova pagina statica dove metti un foto. vai nel pannello dei widget, scegli il sotto menù blockparses. Cerca la pagina che hai salvato e attivala. Torna nel sottomenù gestisci widgets e lo trovi nella lista a destra. Trascinalo dove vuoi visualizzarlo
  • grazie, mi sa che il mio tema non lo consente... (fluxish)...
  • peccato non riesco proprio...non è che c'è un metodo alternativo? magari scrivendo qualche file a mano?
  • Penso sia qualche file di stile... Prova con Firebug o con la consolle sviluppatore di Chrome
  • Forse non ho capito: tu vuoi mettere un'immagine in un widget da aggiungere nella colonna o vuoi un immagine di sfondo nella colonna dei widget? Se è la prima fai come ti ho detto, deve funzionare per forza, se è la seconda devi modificare il foglio di stile del tuo tema, allora è un altro paio di maniche...
  • volevo collocare un logo nella parte destra del blog (con mera funzione decorativa) che rimanesse tale a prescindere dal post visualizzato; insomma, volevo inserire una immagine di circa 100x100 pixel sopra il box di "ricerca". questo è tutto...
  • mi avete abbandonato???
  • metti in una statica un'immagine, crea un widget con il plugin blockparser, posiziona il widget nella colonna
  • Allora, guida passo passo vai nel pannello di amministrazione. Vai nella sezione upload e carica l'immagine che vuoi. Vai nella sezione Statiche e dal sotto menù crea una nuova pagina statica. Metti il titolo e in fondo il nome della pagina uguale al titolo invece che quel nome complicato che viene proposto di default. Come contenuto inserisci l'immagine che hai caricato prima. Se hai abilitato il plugin il BBCode puoi inserirla facilmente dal menù a tendina. Oppure inseriscila così [align=center] img=images/tua-immagine.png] [/align] Salva e vai nella sezione Widget. Entra nella sezione blocparser. Nella lista che trovi dovresti trovare la pagina che hai creato (col nome che hai scelto). Abilitala. Vai nella sezione Gestisci Widget e cerca il plugin chiamato così: "BolckParser: nome che hai scelto" Prendilo e trascinalo dove lo vuoi visualizzare. Salva Fine
  • Ho visto il template (dal vivo nel sito ;) ). Prima della chiusura del div#page, aggiungi questo codice:
    Quindi vai in layout.css alla riga 35 e la fai diventare: #page { background: url("http://3.bp.blogspot.com/_baSQ_Mr9Af8/TUcX-95eK1I/AAAAAAAAADQ/FFn7FuYOSSY/s1600/suocera.jpg") no-repeat scroll right bottom transparent; } Ci cambi indirizzo (quello dentro URL, ho preso l'immagine della suocera tanto per) e il gioco è fatto.
  • @lantaca quando vado nella sezione Widget ed entro nella sezione blocparser mi compare una pagina tutta nera con in cima il footer del sito, e sopra c'è scritto Notice: Undefined index: blockparser in /var/www/virtual/studiolegaledesia.com/htdocs/blog/admin/main.php on line 192 credo ci sia qualcosa che non va...insomma non riesco ad accedere alla schermata con la lista delle pagine da abilitare; e questo a prescindere dal genere di pagina statica che creo...
  • Il plugin blockparser è abilitato?
  • Come dice Piero verifica che il plugin blokparser sia attivo. Inoltre ti suggerisco di usare, anche temporaneamente, la lingua inglese per il blog perchè può essere che la traduzione dia dei problemi. Non so se stai usando italiano o onglese perchè non so quale sia il sito...
  • Il sito lo si vede dagli errori PHP solitamente ;) Secondo me è studiolegaledesia.com/blog/
  • sì, il plugin è abilitato, ed il sito è www.studiolegaledesia.com/blog e con la lingua inglese funziona...quindi lascio questa?
  • Non è necessario. Basta che scarichi una traduzione in italiano che lo supporti, anzi, è strano che quella che hai trovato ti dia questo errore. Se vuoi tenere in italiano, assicurati che ci sia questo file: fp-plugins/blockparser/lang/lang.it-it.php e che il suo contenuto sia il seguente: 'BlockParser Widgets', 'description' => 'Il plugin BlockParser ti permette di creare un widget da una pagina statica.

    Seleziona una o più pagine statiche dalla lista per rendere disponibile il widget corrispondente.

    Ogni nuova pagina statica creata sarà elencata qui.', 'id' => 'Pagina statica', 'title' => 'Titolo', 'action' => 'Azione', 'enable' => 'Abilita', 'disable' => 'Disabilita', 'edit' => 'Modifica', ); $lang['admin']['widgets']['blockparser']['msgs'] = array( 1 => 'Il nuovo widget è disponibile. Aggiungilo al blog dal pannelo principale!', -1 => 'Impossibile creare il widget richiesto', 2 => 'Hai disabilitato un widget: non dimenticarti di togliere qualsiasi riferimento dal pannello principale!', -2 => 'Impossibile disabilitare il widget' ); ?>

  • pierovdfn said: Il sito lo si vede dagli errori PHP solitamente ;)

    Hehe, non avevo letto l'errore... :D Era capitato anche a me che quella pagina desse errore e la colpa era della traduzione. Infatti da quella volta uso FP solo in inglese
  • È colpa di un "bug" che c'è nell'SVN e quindi anche quando hai aggiornato è successo quell'errore... Comunque io invece uso FP in italiano perché la lingua l'ho sempre riguardata... Penso che prima o poi però tradurrò tutto FP da solo, senza partire da quella di Marco Legolas per FP 0.804
  • ...grazie...
  • This discussion has been closed.
    All Discussions
    Start a New Discussion

    Howdy, Stranger!

    It looks like you're new here. If you want to get involved, click one of these buttons!

    In this Discussion