ℹ️
Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
Issue with customized page
  • Hello. I am using FP to power my website http://www.punkrockfilmmaking.com I have embedded FP into the existing layout of my website. Everything works fine when I run it on my local test server, but I get this error when I access the live site:

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/punkrock/public_html/includes/header.php:13) in /home/punkrock/public_html/fp-includes/core/core.session.php on line 11

    Everything still shows up fine and there are no issues that I see, except for this error popping up at the top of the page. Anyone know exactly what this is and how I can fix it? It refers to my custom header. Here is some of the code in that header:

    [code]
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" 
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Punk Rock Filmmaking - Let's Get The Word Out!</title>
    <link href="styles/layout1.css" rel="stylesheet" type="text/css" />
    <link href="/skins/bdf77/styleSheets/style.css" rel="stylesheet" type="text/css" />
    </head>
    [/code]

    After that it is simply the code for my logo and menu. Could it have anything to do with setting the Doc Type, setting the Title or anything like that?
  • If you look at the page, you'll also notice this error:
    "Notice: Undefined index: x in /home/punkrock/public_html/index.php on line 50"

    That is due to one of my scripts. I'll figure that one out later.
  • Here is a screenshot of the error.
  • I think I hit this problem when I integrated FP with a site which already had a separate MySQL membership system - with its own session stuff going on. I don't know if that's what you've got but there's some sort of clash going on there so I've PM'd you with a possible solution which is not something I'd like to earn the wrath of NWM for posting publicly! 

  •  so I've PM'd you with a possible solution which is not something I'd like to earn the wrath of NWM for posting publicly! 


    Hey, you're free to do whatever you feel like ;)
  • I thought editing core files was taboo!
  • Thanks a lot for the fix, Stanley! 
    Now, I just have to go figure out why I'm getting this separate error. :/
  • Start a New Discussion

    Howdy, Stranger!

    It looks like you're new here. If you want to get involved, click one of these buttons!

    In this Discussion