ℹ️
Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
Unable to read resource index.tpl
  • hi i tried to re-install Flatpress on my server an recieve this error message "Warning: Smarty error: unable to read resource: "index.tpl" in /homepages/22/d191737368/htdocs/blog/flatpress/fp-includes/smarty/Smarty.class.php on line 1095" it happen after i unintentional changed my blog to a zipped theme. I've tried deleting my flatpress directory as well as installing a new copy in another location and nothing seems to work. I enjoyed testing this project out and like the fact that it is more portable than any of the databased bloging platforms. thank yo for any help you can offer
  • I'm not sure I understood what you mean with "zipped theme". By the way, if the theme is uncompressed and you get this error, the directory containing the theme (and probably the files) don't have reading permissions, so fix this on your server Anyway you can open fp-content/config/settings.conf.php, search for the field 'theme' => 'your_theme' and set 'your_theme' to a working theme you have such as 'leggero'. Moreover, you can delete %%setup.lock in fp-content/ and re-install the blog browsing to /yourblog//setup.php hope this helps
  • Oh ,when I mention "Zipped themes" i was referring to the unextracted .zip files. Thank you for your help on this Im going to try to do what you suggested later on today. Jon Jonleedesign.com
  • Also when moving sites to another host dont forget to clean all the chache.
  • in this case he should have to clean also the config and specifically fp-content/config/settings.conf.php
This discussion has been closed.
All Discussions
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion