Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
Home page is Not Found
  • Hello, everyone

    my homepage is not working..cant find the entry or static

    I have entry and static, but when i choose anything of page/blog as homepage the result is same : Not Found

    Sorry, we could not find the page you requested

    hope somebody can help..


  • Is your control panel working? 

    Did you enable PrettyURLs? If so, maybe you can try it with that plugin disabled. 
  • Hi Marc, yes control panel is working properly, and Pretty URL alread disabled... any options to set homepage by tweak the code, because by control panel is not working... thanks
  • I would suggest to go to the maintenance panel and choose "rebuild index"
  • I just go to maintenance and did "rebuild index", some file backup, then back to homepage..still same, homepage not found..
  • Is this a newly installed blog, or did you blog use to work and then stopped working for some reason?
  • hello, sorry for a long absence, I did tweak template based legerro and the homepage is working before, but somehow, it suddenly not found. ..thanks here the link
  • Interesting. 

    All your other entries and static pages seem to work. Since the about page works, I'd try to set it at the home page and see what happens. 

    That's weird. 
  • Hi, it seems index is corrupt.
    When do you go to the rebuild index panel, what happens?
    There should be a white page with the list of your entries...
    Could you fix permissions (chmod), too?

    Are you using NoWhereMan's Frontpage?
    What plugins are you using?

  • Hi,
    i am not using NoWhereMan's Frontpage
    plugin mostly standard / flatpress default, i can control the chmod
    does this troubleshooting connected to hosting? it's a free second domain and hosting served by ic.cz 

    this is whate happen when rebuld index



    BACKUP INDEX to fp-content/index1394782149
    [POST] entry140204-151810 => Welcome to Kocky Projekt!
    [POST] entry140206-124939 => Shelby Fitzpatrick
    [POST] entry140209-220603 => Ainars Rimicans
    [POST] entry140209-221338 => Ilze Rimicane
    [POST] entry140209-222615 => Zuzana  lorinczova 
    [POST] entry140209-223514 => Roger LAUTE
    [POST] entry140209-230658 => Pavel Toufar
    [POST] entry140211-194012 => Lenke SIMON
    [POST] entry140212-095859 => Jarmila Pankova
    [POST] entry140212-115917 => Helena Hošková
    [POST] entry140219-122713 => Willy VAN DE VELDE
    [POST] entry140209-225228 => SABBAN Véronique
    [POST] entry140219-124336 => Ann CASSIMONS
    [POST] entry140219-124800 => Kathleen LOTT
    [POST] entry140211-194950 => Dagmar Rehse

    Please, select the back arrow in your browser

  • This is good, at least reading entries works.

    By «Could you fix chmod?», I actually meant «Please, set 0777 to everything in fp-content directory».

    All PHP > 5.0 hosts should work with Flatpress, as I know.
    Please, try to remove any .htaccess file.

    If it doesn't work please download your FP installation and run it in a local webserver or upload it in another host.
  • Hi piero, it's same, home page still not found, i cant find .htaccess (looks like i dont have it), I tried in localhost it's same..chmod no effect...any idea to make a custom home page -a "harsh" methods for non a programmer? thanks
  • hello everyone, does anyone know how to redirect url to static as the option as homepage using backdoor methods..thanks
  • can you see the contents of your blog by browsing to http://yoursite.com/flatpress/index.php?x=paged:1 ?
  • hello, no, I cant's see the content, it's just blank: Not Found The requested URL /flatpress/index.php was not found on this server. Apache/2.2.16 (Debian) Server at catsproject.ic.cz Port 80 thansk
  • hello, sorry, forget my comment above, url mistake, here is the result: I can see header; latestentries widget, footer, but not the content Not Found Sorry, we could not find the page you requested
  • Hi,
    I've seen that the error remains...
    Try to setup Flatpress again, as a brand new installation.
    Download it from Github and upload it in another directory.
    Then import the fp-content/content directory and rebuild the index.
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion