Welcome to the archive of the old FlatPress support forum. Browse more than a decade of FlatPress wisdom! Login is disabled.

The current FlatPress support forum is available here: forum.flatpress.org
entry not printing :(
  • Just downloaded the latest SVN in preparation for 2012 changes to my sites.  A vanilla install and the entry isn't printing either on the entry page or in the admin preview.   Can see the code for 'Welcome to FlatPress' in edit and do everything else but no text is printing other than title, posted by and time.  Any clues?
  • I just downloaded the latest SVN and installed it on my wamp server at home - all seems well on my installation.

    Are you just using the default FP theme?

    Does it show anything unusual in the source code for the pages which are playing up?

  • This is what I'm getting after logging in for the first time:
    Have several other versions of FP up and running on the same XAMPP server without an issue.  Also tried -safe-mode and no difference either.

    <div id="outer-container">
    <div id="main">
    <div id="entry111210-182747" class="entry y-2011 m-12 d-10">
    <h2 class="date">Saturday, December 10, 2011</h2>
    <a href="http://localhost/bio/12test/?x=entry:entry111210-182747">
    Welcome to FlatPress!
    <div class="admincontrols">
    <a href="http://localhost/bio/12test/admin.php?p=entry&amp;entry=entry111210-182747&amp;action=write">[Edit]</a>
    <a href="http://localhost/bio/12test/admin.php?p=entry&amp;entry=entry111210-182747&amp;action=delete">[Delete]</a>
    <ul class="entry-footer">
    <li class="entry-info">Posted by at

    <li class="link-comments">
    <a href="http://localhost/bio/12test/?x=entry:entry111210-182747;comments:1#comments">Add a comment
    Where the h*** is the delete post button?
  • Does it show anything at all in the page source code between the admincontrols div and the entry-footer.

    What happens if you create a new entry - same thing happens?

    I presume there's nothing screwed up in your theme's entry-default.tpl file - i.e. it HAS {$content|tag:the_content} shown there (can't see why it shouldn't - but it's part of the process of elimination to find out what's going wrong)

    Edit: damn, you posted again while I was taking a break from the computer. Looks like your content section is missing. Check your entry-default.tpl file.

  • Same thing happens with a new entry.  :(

    Yes, entry-default.tpl has the content line.

    <div id="{$id}" class="entry {$date|date_format:"y-%Y m-%m d-%d"}">
                    {*     using the following way to print the date, if more     *}
                    {*    than one entry have been written the same day,        *}
                    {*     the date will be printed only once                 *}
            {$date|date_format_daily:"<h2 class=\"date\">`$fp_config.locale.dateformat`</h2>"}
                    <a href="{$id|link:post_link}">
                    {include file=shared:entryadminctrls.tpl}


                    <ul class="entry-footer">
                    <li class="entry-info">Posted by {$author} at
                    {if ($categories)} in {$categories|@filed}{/if}
                    {if !(in_array('commslock', $categories) && !$comments)}
                    <li class="link-comments">
                    <a href="{$id|link:comments_link}#comments">{$comments|tag:comments_number}
                        {if isset($views)}(<strong>{$views}</strong> views){/if}

    Boy . . . this forum's editing controls are a mess . . . .

  • Just for giggles, I installed an older version from last year - November 07, 2010.  No problem.  Worked as expected.
  • Strange, if it's happening with new posts as well. I can't recall reading about this sort of problem before - I searched through the forum to see if there was anything which sounded similar.

    The version I downloaded and installed today was this one...


    I'm guessing that's the same one you're having problems with, but it works just fine for me. Maybe you could try re-downloading it from the above link and try that? Might have been a dead fly in the works on the other one - could take forever to nail down what the cause is.

  • Downloaded from your link.  Setup in under 60 seconds.  Same problem.  Guess I'll have to use the version from last year.  Is there a page listing past SVN versions so I could go back one or two to see when it breaks?  FWIW, I had updated all my blogs to 398 (in the SVN list of changes) a few months ago so the bug is between 398 and 406.  Maybe you could have a look at those - only 7 -  and see if something jumps out at you.  Thanks for your expertize.
  • I think we need to call in the cavalry @NoWhereMan
  • First question: PHP version?
    Second: try and disable the bbcode plugin from the admin panel
  • XAMPP for Linux 1.6.3a
        - PHP 4.4.7
        - PHP 5.2.3

    YEA!!!  The Master speaks . . .  bbcode plugin disabled=problem solved.

    But the blog obviously needs to have bbcode working.  A little project for you . . .    :)
  • Got to thinking about your question and dug a little deeper into the XAMPP configuration.  Hadn't given it a thought for a looong time.  After poking around Google and refreshing my memory, I realized that I had set the php-switch to PHP 4.4.7.  When I switched to PHP 5.2.3 everything was working as normal on FlatPress.  So the incompatibility is with PHP 4.4.7.  Don't know if any servers are even using 4.4.7 these days.  But at least it's narrowed down further if you want to mess with it.  Oh, and sorry for not thinking of this sooner . . .  :)
  • I had to update bbcode lately to support f-ing PHP5 syntax for object instances... btw if you revert to an older version of the plugin it should work on PHP4 as well.
  • I feel your pain! My host is running PHP 4/5 which is why the old versions are working. Just ran a phpinfo and it spit out PHP 5.2.9. So the latest FP version should be fine.
  • FYI just uploaded everything last night and all is well. Flatpress ROCKS! http://www.saynotogmos.org/ud2012/ And to answer a question I posed last year about whether FP would hold up under heavy use. The site averages about 12,000 uniques a month and here's the total number of posts for 2011: http://www.saynotogmos.org/ud2011/index.php/allentries/ There hasn't been one problem (though it is a little slow at times partly from the Google search . . . besides I'm still on dialup so don't know how it works in the 'real' world).
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion