Search found 80 matches

by laborix
Tue Sep 27, 2022 3:51 pm
Forum: General Support
Topic: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search
Replies: 7
Views: 233

Re: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search

... Keyword: ist full-text search Date: September 13, 2022 "Start search" button I then get all the posts that appear to contain the word "ist". But I should only get one post as a result from the viewfinder. ... Ok, very interesting what FlatPress generates from/with PHP comman...
by laborix
Sun Sep 25, 2022 6:56 am
Forum: General Support
Topic: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search
Replies: 7
Views: 233

Re: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search

fraenkiman wrote: Sun Sep 25, 2022 12:14 am... the PHP8.1 compatible ...
The solution work fine on PHP 7.x and PHP 8.x, no matter, you only need a FlatPress Version higher than 1.0 :)
by laborix
Sat Sep 24, 2022 6:17 am
Forum: General Support
Topic: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search
Replies: 7
Views: 233

Re: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search

Sorry, I posted the wrong lines to replace :roll: Please replace lines 190 - 193 in the file "/fp-includes/smarty/plugins/function.html_select_date.php" for ($i = 1; $i <= 12; $i++) { $month_names[$i] = strftime($month_format, mktime(0, 0, 0, $i, 1, 2000)); $month_values[$i] = strftime($mo...
by laborix
Sun Sep 18, 2022 2:00 pm
Forum: General Support
Topic: Flatpress 1.2.1 and PHP 8.0: Warning with [more]-tag
Replies: 1
Views: 95

Flatpress 1.2.1 and PHP 8.0: Warning with [more]-tag

Situation: Install Flatpress and create another blog article. The first blog article in the Flatpress blog contains a [more] tag. If you click on the first blog article and then on [Read more...], the following error message appears in the "this page/next page" section. Warning: Trying to ...
by laborix
Sun Sep 18, 2022 10:28 am
Forum: General Support
Topic: Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search
Replies: 7
Views: 233

Flatpress 1.2.1 issue #132 - Months are displayed in the wrong language in the search

Hi, a quick solution for the Flatpress 1.2.1 problem described in the Flatpress Github here: -> https://github.com/flatpressblog/flatpress/issues/132 Download the file "/fp-includes/smarty/plugins/function.html_select_date.php", edit it with a UTF-8 Editor and replace the lines 227 - 230 f...
by laborix
Wed Sep 14, 2022 4:01 pm
Forum: Theme support
Topic: https don't show theme
Replies: 10
Views: 364

Re: https don't show theme

... no change on https://agrofarm.cz/ ... I'm not sure what's going wrong with your installation, so I think the best way is to do a full new installation of Flatpress like the Upgrade section in the Flatpress Wiki. See full article: https://wiki.flatpress.org/en:doc:basic:upgrade So, please downlo...
by laborix
Tue Sep 13, 2022 3:58 pm
Forum: Theme support
Topic: https don't show theme
Replies: 10
Views: 364

Re: https don't show theme

... FlatPress is 1.2.beta1, it can be a problem? ... I installed Flatpress 1.2 beta 1 in a test enviromnet and take a look for <link media="screen" href="http:// ... but there is no "http://", all is "https://" :?: Ok, let's try something ... Solution 1: Download ...
by laborix
Sun Sep 11, 2022 3:43 pm
Forum: Theme support
Topic: https don't show theme
Replies: 10
Views: 364

Re: https don't show theme

I have problem with all theme, protocol https don't show theme. ... Solution 1: Log In in your Flatpress on your webspace and go to the Options. Change the Blog URL to https://www.agrofarm.cz/ and save the changes. Then clear the cache in Flatpress and it should work. Solution 2: Run the Flatpress ...
by laborix
Wed Jun 29, 2022 3:45 pm
Forum: FlatPress project
Topic: Need help testing: Smarty update
Replies: 11
Views: 2436

Re: Need help testing: Smarty update

... I first tried it with Debian ... What did I miss? ... On Linux systems, it is very important to ensure that the fp-content has the correct access rights. Windows is sometimes a bit more accommodating. I'm not sure, but you could check the fp-content/config folder to see if the correct configura...
by laborix
Wed Jun 29, 2022 3:28 pm
Forum: FlatPress project
Topic: Need help testing: Smarty update
Replies: 11
Views: 2436

Re: Need help testing: Smarty update

... as I'm very much interested in PHP 8.1 compatibility ... a quick test of the Flatpress Smarty 4 version under PHP 8.1 produces the following with maximum error checking: Last Setup Step - Login or page looks Deprecated: Automatic conversion of false to array is deprecated in .../fp-smarty4/fp-p...