Loading front page takes forever

This is the right place to report general bugs, make suggestions or ask for help.
Post Reply
dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Loading front page takes forever

Post by dsteuer » Thu Oct 21, 2021 10:28 am

Hi friends,

just try to load https://steuer-geilke.de/Universaldilettant

It take multiple seconds to show the front page. Any ideas, what may cause that?
Subsequent page calls work as expected.

Detlef

George
Posts: 15
Joined: Tue May 18, 2021 10:54 am
Location: Uk
Contact:

Re: Loading front page takes forever

Post by George » Fri Oct 22, 2021 6:05 pm

Have you tried another theme ?

dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Re: Loading front page takes forever

Post by dsteuer » Fri Oct 22, 2021 6:13 pm

Yes, it is the same with leggero.

User avatar
Arvid
FlatPress Coder
Posts: 328
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Loading front page takes forever

Post by Arvid » Sat Oct 30, 2021 12:27 pm

Hm, this is odd. Only the blog overview page seems to be that slow - static pages such as "About" do not have this problem, neither do the single blog entries. If you were to put a static page as start page, I suspect the initial loading of your blog would be fast again.

Nevertheless, I do not really have an idea where this might come from. Have you tried to purge the caches and rebuild the index (Admin -> Maintain)?

(I really love the word Universaldilettant, by the way :lol: )

All the best,
Arvid

dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Re: Loading front page takes forever

Post by dsteuer » Sat Oct 30, 2021 1:39 pm

Purging the cache does not help.

Another problem, probably related: Sometimes the reading of the rss feed times out resp. is timed out by the
rss reader.

Hmm, maybe I use the workaround and use a static page as startpage. But it remains mysterious,

Detlef

User avatar
Arvid
FlatPress Coder
Posts: 328
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Loading front page takes forever

Post by Arvid » Mon Nov 01, 2021 10:47 am

Detlef,

yes, I also suspect the same origin for the RSS timeout.
Did you rebuild the index as well? (And, if you do so, does this also take a few seconds? Normally, it should be done in an instant.)

All the best,
Arvid

dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Re: Loading front page takes forever

Post by dsteuer » Mon Nov 01, 2021 10:35 pm

Rebuilding the index happens in an instant, but does not help.

dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Re: Loading front page takes forever

Post by dsteuer » Sun Jan 23, 2022 9:28 pm

Sone systematic searching reveals the culprit: photoswipe needs the time to process the images. It seems all pictures are re-processed when accessingg index.php. Any idea how to speed up the process?

it is fast to directly access a page with pictures. It is slow to acces the index.php or rss.php.
Any idea?
Detlef

dsteuer
Posts: 47
Joined: Sun May 24, 2020 11:21 am

Re: Loading front page takes forever

Post by dsteuer » Wed Feb 23, 2022 9:24 pm

Ping, Or any idea how I can help to debug? Loading the rss feed each time takes an eternity. May be that is a starting point?

User avatar
Arvid
FlatPress Coder
Posts: 328
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Loading front page takes forever

Post by Arvid » Sun Mar 13, 2022 12:14 pm

dsteuer wrote: ↑Sun Jan 23, 2022 9:28 pm Sone systematic searching reveals the culprit: photoswipe needs the time to process the images. It seems all pictures are re-processed when accessingg index.php. Any idea how to speed up the process?

it is fast to directly access a page with pictures. It is slow to acces the index.php or rss.php.
Any idea?
Detlef
When you deactivate the PhotoSwipe plugin, the start page is loading as fast as expected?
Which version of the Plugin are you running?

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests