Can't Install, keep getting delete settingup.lock to restart

This is the right place to report general bugs, make suggestions or ask for help.
Post Reply
rhays
Posts: 6
Joined: Fri Sep 20, 2019 2:38 pm

Can't Install, keep getting delete settingup.lock to restart

Post by rhays » Fri Sep 20, 2019 2:53 pm

NAME="Ubuntu"
VERSION="18.04.3 LTS (Bionic Beaver)"
nginx version: nginx/1.14.0 (Ubuntu )
PHP 7.2.19-0ubuntu0.18.04.2 (cli) (built: Aug 12 2019 19:34:28)
FLATPRESS 1.1 and 1.0.3_PHP7
Don't think this matters but all of this is running on a Tinker S board using ARM

I am trying to install FLATPRESS to my server and for the sake of argument,
the directory owner: www-data, chmod: 777. I call up my domain
(https://whatgripesme.com) and it takes me to the setup screen, tells me it
needs to ask a few questions and it won't take to long, I hit the NEXT
button and I get a white screen with a message: "Setup is running: if you
are the owner, you can delete fp-content/settingup.lock to restart".

No matter what I do by deleting it. And try to start again, it still comes back and I do not get the setup screen.

I have used 2 browsers (CHROME, EDGE) and I have tried two FLATPRESS's 1.1 (Including redownloading and installing) and 1.0.3_PHP7 versions.

This question was asked on the old forum: (http://flatpress.org/vanilla2/discussio ... l-error/p1), that does not exist now.

Any suggestions?

User avatar
Arvid
FlatPress Coder
Posts: 40
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Can't Install, keep getting delete settingup.lock to restart

Post by Arvid » Fri Sep 20, 2019 6:53 pm

Hi, welcome aboard :)

The old forum isn't gone, i have it. But I still search for a safe way to run it in strict read-only mode.
Until then, archive.org once again proves to be very useful: https://web.archive.org/web/20120610052 ... l-error/p1 - not sure though if that helps with the matter.

I never experienced such problems, but I always ran FlatPress on Apache - no experiences with nginx. Did you try Apache as comparison?
Helpful FlatPress links: Project blog πŸ“ - FlatPress wiki πŸ“– - FlatPress@Twitter 🐦
Stay up to date with our feeds: Forum RSS feed πŸ“œ - Project blog RSS feed πŸ“œ


πŸ‡©πŸ‡ͺ Oktober 2019: Habe aktuell fΓΌr meinen Arbeitgeber hier im Ruhrgebiet Stellen zu besetzen! πŸ‡©πŸ‡ͺ
- Softwareentwickler (Webanwendungen) - unbefristet, sofort
- Studentische Hilfskraft IT - unbefristet, sofort
- Auszubildender Fachinformatiker Anwendungsentwicklung - Sommer 2020

rhays
Posts: 6
Joined: Fri Sep 20, 2019 2:38 pm

Re: Can't Install, keep getting delete settingup.lock to restart

Post by rhays » Fri Sep 20, 2019 7:15 pm

So I tried one more thing as it was about the only other thing that I thought that might cause it.. Its (HTTPS) I commented out my (HTTPS) settings and everything (Setup wise) worked. So I am not sure how the setup is configured (I have not looked but if it is forcing (HTTP) or it's required then maybe a note to say you have to install using (HTTP) or the code will need to be adjusted.

Hope this helps.

Rick

---------------------------------------------------

Part 2:

I got it to install using (HTTP) set the DOMAIN address in setup to my (HTTPS) setup completed, tried to run default FLATPRESS and I have no CSS extra, looked at the source and found it is still calling everything from (HTTP) even though I am on (HTTPS) and the settings.conf.php is set too:

<?php

$fp_config = array (
'general' =>
array (
'www' => 'https://whatgripesme.com/',
'title' => 'FLATPRESS',
'subtitle' => 'My FlatPress blog',
'footer' => '',
'author' => 'Walter',
'email' => 'rhays@haysgang.com',
'startpage' => NULL,
'maxentries' => '5',
'notify' => true,
'theme' => 'leggero',
'style' => 'leggero',
'blogid' => 'fp-e601d1',
'charset' => 'utf-8',
),
'locale' =>
array (
'timeoffset' => '2',
'timeformat' => '%H:%M:%S',
'dateformat' => '%A, %B %e, %Y',
'dateformatshort' => '%Y-%m-%d',
'charset' => 'utf-8',
'lang' => 'en-us',
),
'plugins' =>
array (
'blockparser' =>
array (
'pages' =>
array (
0 => 'menu',
1 => 'about',
),
),
'mediamanager' =>
array (
'usecount' =>
array (
),
),
),
);

?>

Any suggestions on how to run under (HTTPS) from setup? Am I missing a config setting? Thanks for any help.

User avatar
Arvid
FlatPress Coder
Posts: 40
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Can't Install, keep getting delete settingup.lock to restart

Post by Arvid » Fri Sep 20, 2019 8:53 pm

Rick, thank you for testing and reporting in this detailled manner. This looks like HTTPS support of the installer isn't quite complete, I created an issue on GitHub: https://github.com/flatpressblog/flatpress/issues/52

I don't understand the CSS problem, though. From 1.0.3.php7, I never had HTTPS trouble on the website itself (still need to check the installer). You have 1.1 running, I assume? Could you please try to fiddle around with your blog URL in the admin panel options? Adding "www", changing "https" to "http" (although this sounds silly to me - just to check if the problem comes from there).
Helpful FlatPress links: Project blog πŸ“ - FlatPress wiki πŸ“– - FlatPress@Twitter 🐦
Stay up to date with our feeds: Forum RSS feed πŸ“œ - Project blog RSS feed πŸ“œ


πŸ‡©πŸ‡ͺ Oktober 2019: Habe aktuell fΓΌr meinen Arbeitgeber hier im Ruhrgebiet Stellen zu besetzen! πŸ‡©πŸ‡ͺ
- Softwareentwickler (Webanwendungen) - unbefristet, sofort
- Studentische Hilfskraft IT - unbefristet, sofort
- Auszubildender Fachinformatiker Anwendungsentwicklung - Sommer 2020

rhays
Posts: 6
Joined: Fri Sep 20, 2019 2:38 pm

Re: Can't Install, keep getting delete settingup.lock to restart

Post by rhays » Fri Sep 20, 2019 10:51 pm

Not at home, when I get home I will try those suggestions, and I will try installing with the 1.0.3-php7 version to see if that helps things, I did clone the program, I may look at it and see if I see anything that might help the install with (HTTPS), if so I will fork and push up my suggestions.

Rick

rhays
Posts: 6
Joined: Fri Sep 20, 2019 2:38 pm

Re: Can't Install, keep getting delete settingup.lock to restart

Post by rhays » Sat Sep 21, 2019 4:07 pm

So here was the problem.

I run NGINX, but I also run a reverse proxy. In defaults.php was not setting $serverport = "https://" due to the fact NGINX was not passing $_SERVER['HTTPS']) = 'on'

The fix is simple once the true problem was known. Change your NGINX virtual host setting in the PHP part as follows.
FROM:

Code: Select all

server
{
	location ~ \.php$ 
	{
		include snippets/fastcgi-php.conf;
		fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
	}
}
TO:

Code: Select all

server
{
	location ~ \.php$ 
	{
		# Make PHP-FPM aware that this vhost is HTTPs enabled
		include fastcgi_params;
		fastcgi_param HTTPS on;	

		include snippets/fastcgi-php.conf;
		fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
	}
}
The mainline to add to the script is the: fastcgi_param HTTPS on; as this tell NGINX to pass the HTTPS variable.

Hope this helps someone in the future save a little time. Now time to build a blog.. :mrgreen:

Nothing wrong with the code, so you can remove the issue if you would like or if you want me to follow up with the answer I can do that as well.

Rick

User avatar
Arvid
FlatPress Coder
Posts: 40
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Can't Install, keep getting delete settingup.lock to restart

Post by Arvid » Sun Oct 06, 2019 11:28 am

Rick, thanks for sharing the solution. I closed the issue.
Helpful FlatPress links: Project blog πŸ“ - FlatPress wiki πŸ“– - FlatPress@Twitter 🐦
Stay up to date with our feeds: Forum RSS feed πŸ“œ - Project blog RSS feed πŸ“œ


πŸ‡©πŸ‡ͺ Oktober 2019: Habe aktuell fΓΌr meinen Arbeitgeber hier im Ruhrgebiet Stellen zu besetzen! πŸ‡©πŸ‡ͺ
- Softwareentwickler (Webanwendungen) - unbefristet, sofort
- Studentische Hilfskraft IT - unbefristet, sofort
- Auszubildender Fachinformatiker Anwendungsentwicklung - Sommer 2020

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest