Page 1 of 1

New article but with 2 hours back

Posted: Tue Apr 07, 2020 7:27 pm
by Panther
When I create a new article (update flatpress few days ago from 1.0.3 to 1.1), the hour of article in just 2 hours back than italian time.

Example
I create a new article now (in Italy 21.24) on article it appears 19:24, so I have to change every time.

I went to options and there is:
Time should differ by 2 hours

I tried to change the hours (from 0 to 4), but without resolving.

Something is changed about time in new version of FlatPress ?
Thank you

Re: New article but with 2 hours back

Posted: Wed Apr 08, 2020 3:32 pm
by laborix
Panther wrote:
Tue Apr 07, 2020 7:27 pm
… I tried to change the hours (from 0 to 4), but without resolving. ...
I tested it on IIS with PHP 7.2 and on Apache with PHP 7.3, on both Environments it works :oops:

Start an FTP Programm and set manual the directory permissions of the config folder to modify, clear the Cache folder and try again.

If this doesn't work, please, made a hardcore test. Download following file from your webspace:
/fp-content/config/settings.conf.php
and edit the line with "timeoffset", upload the file and clear the Cache Folder again. Try again.

Re: New article but with 2 hours back

Posted: Thu Apr 09, 2020 8:24 pm
by Panther
Start an FTP Programm and set manual the directory permissions of the config folder to modify, clear the Cache folder and try again.
config folder is 0777
settings.conf.php is 0777

I set it with 0755 but it doesn't work.


If this doesn't work, please, made a hardcore test. Download following file from your webspace:
/fp-content/config/settings.conf.php
and edit the line with "timeoffset", upload the file and clear the Cache Folder again. Try again.

I must disable #'timeoffset' => '2' ?

Re: New article but with 2 hours back

Posted: Fri Apr 10, 2020 10:20 am
by laborix
Panther wrote:
Thu Apr 09, 2020 8:24 pm
… I must disable #'timeoffset' => '2' ? ...
No, only the number '2' to a number of Hours you need.

Re: New article but with 2 hours back

Posted: Wed Apr 15, 2020 11:37 am
by Arvid
Did changing the config file manually help?

Re: New article but with 2 hours back

Posted: Sat Apr 18, 2020 11:11 pm
by Panther
No, I change the hour every time when I have to post an article.
If it is possible in any way, otherwise, no problem.

Re: New article but with 2 hours back

Posted: Sun Apr 19, 2020 10:40 am
by Arvid
This is very odd :(

Changing the time offset has no effect at all? Is the new value stored in the config file at least?

Re: New article but with 2 hours back

Posted: Sun Apr 26, 2020 9:12 pm
by Tongara
This happened to me when I first started out with FlatPress.

I changed the setting in the config and it still didn't work. Then, when the date changed to the following day on the server it suddenly displayed the correct time with new posts. No idea why there was a delay.

Re: New article but with 2 hours back

Posted: Sat May 09, 2020 11:06 am
by Arvid
This is strange indeed - really no idea what could have gone wrong there. As long as it works now ...