Flatpress 1.2.1 and PHP 8.0: Warning with [more]-tag

This is the right place to report general bugs, make suggestions or ask for help.
Post Reply
laborix
Posts: 80
Joined: Sat Feb 16, 2019 3:51 pm

Flatpress 1.2.1 and PHP 8.0: Warning with [more]-tag

Post by laborix » Sun Sep 18, 2022 2:00 pm

Situation:
Install Flatpress and create another blog article. The first blog article in the Flatpress blog contains a [more] tag. If you click on the first blog article and then on [Read more...], the following error message appears in the "this page/next page" section.

Code: Select all

Warning: Trying to access array offset on value of type null in .../fp-includes/core/core.wp-pluggable-funcs.php on line 66
Warning: Undefined array key 1 in .../fp-includes/core/core.fpdb.class.php on line 935
This only happens if the very first blog article contains a [more] tag.

User avatar
Arvid
FlatPress Coder
Posts: 405
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Flatpress 1.2.1 and PHP 8.0: Warning with [more]-tag

Post by Arvid » Sat Oct 01, 2022 7:28 pm

Hi,

thanks for reporting! :)
Can you still reproduce this with the current master? I was quite sure we fixed this with 92475a3.

All the best,
Arvid
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich zwei Stellen zu besetzen: Junior-Systemadministrator, Ausbildung zum Fachinformatiker Systemintegration 🇩🇪

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest