https don't show theme

Ask questions about FlatPress themes, present your themes, request new themes.
Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

Re: https don't show theme

Post by Lubomír Ludvík » Mon Sep 19, 2022 7:15 am

Arvid wrote: Mon Sep 19, 2022 4:44 am Now call your blog via HTTPS - does the blog_baseurl start with "http://" again?
Again, see footer on https://www.agrofarm.cz/
It looks like provider doesn't support https.

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: https don't show theme

Post by Arvid » Sun Oct 02, 2022 11:00 am

Okay, then please add the "echo" line to defaults.php, line 124. What does it output on your blog?

Code: Select all

ini_set('session.cookie_secure', 1);
// \/ ADD THIS LINE \/
echo 'Test: "' . $_SERVER ['HTTPS'] . '"';
// /\ ADD THIS LINE /\
if (isset($_SERVER ['HTTPS']) && ($_SERVER ['HTTPS'] == '1' || strtolower($_SERVER ['HTTPS']) == 'on')) {
	$serverport = "https://";
} else {
	$serverport = "http://";
}
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

User avatar
fraenkiman
Posts: 56
Joined: Thu Feb 03, 2022 7:25 pm
Location: Berlin, Germany
Contact:

Re: https don't show theme

Post by fraenkiman » Sun Oct 02, 2022 11:27 pm

Hello, everyone,

I've been reading this topic for a while.

What is strange, for HTTPS a nginx/1.13.3 responds. An Apache also responds to HTTP.

The server configuration has to be straightened out. This will not be solvable with FlatPress.

@Lubomír Ludvík: Do you host yourself and also resolve DNS yourself or are both servers located at the provider?

Best Regards
Frank
My Flatpress-Blog [German]: https://frank-web.dedyn.io

Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

Re: https don't show theme

Post by Lubomír Ludvík » Thu Oct 13, 2022 6:06 am

output: Test: "" Test2: ""

Code: Select all

     echo 'Test: "' . $_SERVER ['HTTPS'] . '"';
if (isset($_SERVER ['HTTPS']) && ($_SERVER ['HTTPS'] == '1' || strtolower($_SERVER ['HTTPS']) == 'on')) {
	$serverport = "https://";
	// Uses a secure connection (HTTPS) if possible
	ini_set('session.cookie_secure', 1);
      echo 'Test1: "' . $_SERVER ['HTTPS'] . '"';
} else {
      echo 'Test2: "' . $_SERVER ['HTTPS'] . '"';
    $serverport = "http://";
}

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: https don't show theme

Post by Arvid » Sat Oct 22, 2022 10:30 am

So your server does not realize it's been called via HTTPS. Best is to contact your hoster with the code from your test script and its output. This might be some configuration glitch on the web server.
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests