Github Flatpress 769 - PHP 8.1.13 - PHP Warning: Deprecated

For devs and testers: Tests of current development versions, technical details of the code.
Post Reply
laborix
Posts: 99
Joined: Sat Feb 16, 2019 3:51 pm

Github Flatpress 769 - PHP 8.1.13 - PHP Warning: Deprecated

Post by laborix » Sun Dec 11, 2022 3:57 pm

after the setup of Flatpress 1.3 dev - Github 769 I wanted to log in. The following PHP deprecated warning appears in the login dialogue:

Code: Select all

PHP Deprecated:  Using php-function "wp_specialchars" as a modifier is deprecated and will be removed in a future release. Use Smarty::registerPlugin to explicitly register a custom modifier. in ../fpgit769/fp-includes/smarty-4.3.0/libs/sysplugins/smarty_internal_compile_private_modifier.php on line 114

PHP Deprecated:  Using php-function "wp_specialchars" as a modifier is deprecated and will be removed in a future release. Use Smarty::registerPlugin to explicitly register a custom modifier. in ../fpgit769/fp-includes/smarty-4.3.0/libs/sysplugins/smarty_internal_compile_private_modifier.php on line 114
The same happens when you log out of the Flatpress Admin interface :roll:

laborix
Posts: 99
Joined: Sat Feb 16, 2019 3:51 pm

Re: Github Flatpress 769 - PHP 8.1.13 - PHP Warning: Deprecated

Post by laborix » Sun Dec 18, 2022 10:45 am

Just for your information, the PHP warning also applies to the current Github 786 version.

Github Flatpress 786 - PHP 8.1.13 - PHP Warning: Deprecated

Code: Select all

PHP Deprecated:  Using php-function "wp_specialchars" as a modifier is deprecated and will be removed in a future release. Use Smarty::registerPlugin to explicitly register a custom modifier. in ../fpgit786/fp-includes/smarty-4.3.0/libs/sysplugins/smarty_internal_compile_private_modifier.php on line 114

PHP Deprecated:  Using php-function "wp_specialchars" as a modifier is deprecated and will be removed in a future release. Use Smarty::registerPlugin to explicitly register a custom modifier. in ../fpgit786/fp-includes/smarty-4.3.0/libs/sysplugins/smarty_internal_compile_private_modifier.php on line 114
Tested locally with Apache and online with an established provider with PHP production settings.

User avatar
Arvid
FlatPress Coder
Posts: 485
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Github Flatpress 769 - PHP 8.1.13 - PHP Warning: Deprecated

Post by Arvid » Sun Dec 18, 2022 11:25 am

This is due to the update from Smarty 4.2 to 4.3 - PHP functions used as modifier must now be registered as modifier explicitly. Fixed it :)
(And by the way, the username input in the login form finally has autofocus now - this bothered me for sooo long :lol: )

Thanks and all the best,
Arvid

laborix
Posts: 99
Joined: Sat Feb 16, 2019 3:51 pm

Re: Github Flatpress 769 - PHP 8.1.13 - PHP Warning: Deprecated

Post by laborix » Mon Dec 19, 2022 4:34 pm

It works fine, Thank you :)

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests