FlatPress Github 892, nginx 1.22 and plugin photoswipe

Find help with FlatPress plugins, report a plugin bug, request or present new plugins.
Post Reply
laborix
Posts: 118
Joined: Sat Feb 16, 2019 3:51 pm

FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by laborix » Tue Apr 11, 2023 5:08 pm

While testing with a FP blog with gallery, more PHP warnings appear:

Code: Select all

Warning: Undefined array key "default" in .../fpgit892/fp-plugins/photoswipe/photoswipefunctions.class.php on line 42
Deprecated: strpos(): Passing null to parameter #1 ($haystack) of type string is deprecated in .../fpgit892/fp-plugins/photoswipe/photoswipefunctions.class.php on line 45
Warning: Undefined array key 0 in .../fpgit892/fp-plugins/photoswipe/photoswipefunctions.class.php on line 73
Deprecated: strlen(): Passing null to parameter #1 ($string) of type string is deprecated in .../fpgit892/fp-plugins/photoswipe/photoswipefunctions.class.php on line 74
Warning: Trying to access array offset on value of type null in .../fpgit892/fp-plugins/photoswipe/photoswipefunctions.class.php on line 74
The current PHP 8.1 version is used and in this case the warning appears in the Webbrowser window.

User avatar
fraenkiman
Posts: 223
Joined: Thu Feb 03, 2022 7:25 pm
Location: Berlin, Germany
Contact:

Re: FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by fraenkiman » Sun Apr 16, 2023 3:47 pm

Hello Laborix,

Thank you very much for reporting. I have opened an issue on this.

With best weekend greetings
Frank
:pencil: You are strong in PHP and Java Script? :point_right: Then help us to improve FlatPress. :point_left:

:exploding_head: Looking for ideas, templates, examples and answers to frequently asked questions?
:bulb: You'll find it here.

My :de: FlatPress-Blog: https://frank-web.dedyn.io

User avatar
Arvid
FlatPress Coder
Posts: 580
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by Arvid » Sun Dec 31, 2023 6:18 pm

Matthias, thanks for reporting, and Frank, thanks for creating the issue!
I'll have to inspect this; the issue is now part of the 1.3 milestone.

You two, please enjoy a fantastic New Year's Eve - "good slide" oder so :)

User avatar
Arvid
FlatPress Coder
Posts: 580
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by Arvid » Sun Jan 21, 2024 12:18 pm

Matthias,

are you still able to reproduce this? I have E_ALL error logging enabled on my apache, but the error does not seem to occur (1.3 beta 1).
If reproducable: What is the content of your entry that triggers the error?

All the best,
Arvid

laborix
Posts: 118
Joined: Sat Feb 16, 2019 3:51 pm

Re: FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by laborix » Sun Jan 21, 2024 4:14 pm

Arvid wrote: ↑Sun Jan 21, 2024 12:18 pm... are you still able to reproduce this? ...
I can no longer reproduce the error as I no longer use this environment.

The current test environment with "error_reporting = E_ALL":
Nginx 1.24, PHP 8.1.27 and FlatPress Github 1142

The FlatPress Github 1142 version with PrettyURLs and activated Photoswipe plugin runs in the quick test without PHP errors. Clicking through the FlatPress-Leggero theme style gallery images went through without a PHP error message.
Thus, the error case #235 could be closed.

User avatar
Arvid
FlatPress Coder
Posts: 580
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress Github 892, nginx 1.22 and plugin photoswipe

Post by Arvid » Sun Jan 21, 2024 7:46 pm

Okay, thanks for checking. I closed the issue :)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest