FlatPress 1.3: Beta 1 released, please help testing

General information and announcements regarding the FlatPress project
Post Reply
User avatar
Arvid
FlatPress Coder
Posts: 541
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

FlatPress 1.3: Beta 1 released, please help testing

Post by Arvid » Sat Jan 20, 2024 8:07 pm

Hi folks,

I just released the first beta version of FlatPress 1.3 - please see my announcement on the project blog.
Also, check out the FlatPress 1.3 "Andante" - Beta 1 release on GitHub to find the detailed change log, a download package and an update package from FlatPress 1.2.

Call for testing help
If you happen to find the time, please help us testing this new version.
There are still a few smaller issues open that keep 1.3 from final release (see the milestone on GitHub). We'll add all the problems you might find to this list - as soon as it is empty, we have our final release!

How to test
This is a beta version - I strongly recommend not using it in your productive blog yet. For testing, it is better to ...
  • ... install a fresh new FlatPress 1.3.
    For this, please use the 1.3.beta1 download package.
  • ... run an update on a copy (!) of your existing blog.
    Simply copy your existing FlatPress 1.2 instance to another (sub-) directory and apply the 1.2 to 1.3 update package.
How to report issues
Please let us know any findings and bugs you stumble upon here on this forum topic. Did the installer run smoothly? Are the reported bugs fixed? Do the new plugins and features look and work good? In case you tried the update package: Does everything keep working and looking as expected?


Thank you very much for your support and your testing!
All the best,
Arvid

User avatar
Arvid
FlatPress Coder
Posts: 541
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress 1.3: Beta 1 released, please help testing

Post by Arvid » Sun Jan 21, 2024 2:02 pm

Just to share my own experiences while testing - maybe someone will find that helpful: I just updated a copy of the official FlatPress site flatpress.org under PHP 8.2.

What I did:
  • Following the release notes, I simply took the update package 12to13beta1.zip, unzipped it and copied its contents into my FlatPress folder (overwriting existing files).
Problems I ran into:
  • After the update, I opened my FlatPress in the web browser - and only got an ugly error message:
    Fatal error: Uncaught --> Smarty Compiler: Syntax error in template "file:/[...]/fp-interface/themes/[theme name]/admin.tpl" on line 1 "{include file=cpheader.tpl}" - Unexpected ".", expected one of: "}" <-- thrown in [...]/fp-interface/themes/[theme name]/admin.tpl on line 1
    The problem lies within the template files of my theme (fp-interface/themes/[theme name]/*.tpl), and is described in the upgrade guide on our wiki: File includes have to be quoted!
    Wrong:

    Code: Select all

    {include file=cpheader.tpl}
    Correct:

    Code: Select all

    {include file="cpheader.tpl"}
    After adding quotes to each include in every template file of my theme, everything works fine :)
Other findings:
  • The new plugins (such as PhotoSwipe) are not automatically enabled after the update. If you wish to use them, you have to enable them in the Admin Area.

All the best,
Arvid

User avatar
Arvid
FlatPress Coder
Posts: 541
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress 1.3: Beta 1 released, please help testing

Post by Arvid » Tue Jan 23, 2024 7:15 pm

I just checked the PHP 8.3 migration guide. None of the backward incompatibilities an deprecations listed there affect the current FlatPress code. Also, I can't trigger any errors while testing under PHP 8.3.

Therefore, I hereby declare that FlatPress 1.3 "Andante" is PHP 8.3 ready.

I have updated change log, release notes, Tech FAQ and release announcement accordingly.

Tongara
Posts: 77
Joined: Wed Jan 22, 2020 11:09 am
Location: Birmingham, UK
Contact:

Re: FlatPress 1.3: Beta 1 released, please help testing

Post by Tongara » Wed Jan 31, 2024 10:23 am

Used the updater package, and 500 errors. Literally can't access my site.

No idea why, as it was fine right before updating. Even changing from PHP 8.0 to 8.1 and enabling intl didn't fix it, and neither did reapplying permissions to all files.

Will return back to the last version for now and wait until the full release to see if that fixes it at that point.

User avatar
fraenkiman
Posts: 195
Joined: Thu Feb 03, 2022 7:25 pm
Location: Berlin, Germany
Contact:

Re: FlatPress 1.3: Beta 1 released, please help testing

Post by fraenkiman » Wed Jan 31, 2024 11:22 pm

Hello Peter,

Thank you very much for your feedback.
Tongara wrote: ↑Wed Jan 31, 2024 10:23 am Used the updater package, and 500 errors. Literally can't access my site.
Meh, that's not supposed to happen.
It is possible that the theme/style you are using is not adapted to Smarty4. Just a wild guess.
Can you provide us with some excerpts from your server log?

With best regards
Frank
:pencil: You are strong in PHP and Java Script? :point_right: Then help us to improve FlatPress. :point_left:

:exploding_head: Looking for ideas, templates, examples and answers to frequently asked questions?
:bulb: You'll find it here.

My :de: FlatPress-Blog: https://frank-web.dedyn.io

User avatar
Arvid
FlatPress Coder
Posts: 541
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: FlatPress 1.3: Beta 1 released, please help testing

Post by Arvid » Sat Feb 03, 2024 11:27 am

Tongara wrote: ↑Wed Jan 31, 2024 10:23 am Used the updater package, and 500 errors. Literally can't access my site.

No idea why, as it was fine right before updating. Even changing from PHP 8.0 to 8.1 and enabling intl didn't fix it, and neither did reapplying permissions to all files.

Will return back to the last version for now and wait until the full release to see if that fixes it at that point.
Hi, thanks for your feedback.
I strongly suspect that the theme is not compatible with Smarty 4 - can you try again, but please switch to the Leggero theme before updating. Is your blog working normally after the update?

Thanks,
Arvid

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests