FlatPress 1.3.1 - PHP 8.4.0 Alpha 1

For devs and testers: Tests of current development versions, technical details of the code.
Post Reply
laborix
Posts: 120
Joined: Sat Feb 16, 2019 3:51 pm

FlatPress 1.3.1 - PHP 8.4.0 Alpha 1

Post by laborix » Sun Jul 07, 2024 7:25 am

FlatPress 1.3.1 Quick&Dirty Test

Test Server Environment:
Apache 2.4 with FastCGI Interface and PHP 8.4.0 Alpha 1

Code: Select all

PHP Deprecated:  Smarty_Internal_Method_GetTemplateVars::getTemplateVars(): Implicitly marking parameter $_ptr as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_method_gettemplatevars.php on line 34
PHP Deprecated:  Smarty_Internal_Method_GetTemplateVars::_getVariable(): Implicitly marking parameter $_ptr as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_method_gettemplatevars.php on line 87
PHP Deprecated:  Smarty_Internal_TemplateCompilerBase::compileTemplate(): Implicitly marking parameter $parent_compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 386
PHP Deprecated:  Smarty_Internal_TemplateCompilerBase::compileTemplateSource(): Implicitly marking parameter $parent_compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 417
PHP Deprecated:  Smarty_Internal_Runtime_CodeFrame::create(): Implicitly marking parameter $compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_runtime_codeframe.php on line 28
PHP Deprecated:  Smarty_Resource_Custom::populate(): Implicitly marking parameter $_template as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_resource_custom.php on line 48

User avatar
fraenkiman
Posts: 235
Joined: Thu Feb 03, 2022 7:25 pm
Location: Berlin, Germany
Contact:

Re: FlatPress 1.3.1 - PHP 8.4.0 Alpha 1

Post by fraenkiman » Tue Jul 09, 2024 9:01 pm

Hello Laborix,

Thank you for the quick & dirty test. That was to be expected. I have recorded it here. Smatry 4 (including Smarty 4.5.3) only supports PHP 7.1 to PHP 8.3. We will have to get used to Smarty 5 in the near future.

With best regards
Frank
:pencil: You are strong in PHP and Java Script? :point_right: Then help us to improve FlatPress. :point_left:

:exploding_head: Looking for ideas, templates, examples and answers to frequently asked questions?
:bulb: You'll find it here.

My :de: FlatPress-Blog: https://frank-web.dedyn.io

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests