strange observation, maybe bug in -master and -issue64

This is the right place to report general bugs, make suggestions or ask for help.
Post Reply
dsteuer
Posts: 32
Joined: Sun May 24, 2020 11:21 am

strange observation, maybe bug in -master and -issue64

Post by dsteuer » Fri Oct 23, 2020 8:54 pm

After installing -issue64 and a simple login/logout, without doing anything, under "last entries" the example page is prepended with [edit].
The edit link does not work. When clicked the page refreshes and [edit] is gone.

I see the same with master, but with that installation I had played aroound a bit.

Can't remember that phenomenon from earlier attempts may be overlooked it?

User avatar
Arvid
FlatPress Coder
Posts: 217
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: strange observation, maybe bug in -master and -issue64

Post by Arvid » Sat Oct 24, 2020 7:21 pm

Thanks for reporting this. Sounds like a cache problem - does it still occur when you refresh the FlatPress caches (Admin area -> Maintain -> Purge theme and templates cache)?

dsteuer
Posts: 32
Joined: Sun May 24, 2020 11:21 am

Re: strange observation, maybe bug in -master and -issue64

Post by dsteuer » Sat Oct 24, 2020 8:37 pm

No, does not help. With and without clearing the cache the same appearance.

After logout the right panel still shows [logout] , resp shows what it shows when logged in.
Admin Area
Add Entry
Logout

and

[edit] Welcome to flatpress.

Reloading changes to what would be expected. (all with -issue64 branch)

Detlef

User avatar
Arvid
FlatPress Coder
Posts: 217
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: strange observation, maybe bug in -master and -issue64

Post by Arvid » Mon Dec 28, 2020 11:50 am

I was able to reproduce this behaviour, it's not related to the issue64 branch.

If you log out from your main page, the "edit" links of the LastEntries plugin stay. (It disappears with the next action.) If you click on it, you are redirected to the login form (which you come from, so it looks like nothing happened). This is correct since you called the URL to edit the entry, and you need to be logged in for that. What is not correct is that the edit link is shown after logout.

I opened an issue for it, thanks for reporting!

All the best,
Arvid

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests