Installer (not installing) - SOLVED

This is the right place to report general bugs, make suggestions or ask for help.
Post Reply
gareth
Posts: 1
Joined: Mon Dec 27, 2021 7:13 pm

Installer (not installing) - SOLVED

Post by gareth » Mon Dec 27, 2021 7:50 pm

Greetings :-)

Thought I'd continue this post even though I've fixed the problem, in the hope that it helps someone else...

I was getting the installer page served "FlatPress Installer - Welcome to Flatpress - etc..." but clicking the [Next>] button just recycled the page.

It was doing this using Apache2 and using Lighttpd, both on a Linux Mint box.

I found a previous post from 2010 that described the same thing: archive/discussion/comment/6539#Comment_6539

Anyway, the problem seems to have been that although I'd set write permissions recursively for my /var/www when setting up the server, when I copied the Flatpress file structure over it didn't acquire those permissions. Re-doing chmod made it work.

Happy Now - maybe I can try and stick back on some of the hair I tore out ;-)

User avatar
Arvid
FlatPress Coder
Posts: 283
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Installer (not installing) - SOLVED

Post by Arvid » Sun Jan 23, 2022 11:24 am

Hi and welcome to FlatPress!

Glad everything worked out fine, hope you don't have to wear a hat now :lol:
Didn't the installer warn you about the missing file permissions?

All the best
Arvid

Post Reply

Who is online

Users browsing this forum: Majestic-12 [Bot] and 0 guests