https don't show theme

Ask questions about FlatPress themes, present your themes, request new themes.
Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

https don't show theme

Post by Lubomír Ludvík » Sun Sep 11, 2022 4:18 am

I have problem with all theme, protocol https don't show theme.
You don't know the solution?

In web source is http://

Code: Select all

<link media="screen" href="http://
http://www.agrofarm.cz/
https://www.agrofarm.cz/
agro.png
agro.png (71.34 KiB) Viewed 490 times

laborix
Posts: 92
Joined: Sat Feb 16, 2019 3:51 pm

Re: https don't show theme

Post by laborix » Sun Sep 11, 2022 3:43 pm

Lubomír Ludvík wrote: Sun Sep 11, 2022 4:18 am I have problem with all theme, protocol https don't show theme. ...
Solution 1:
Log In in your Flatpress on your webspace and go to the Options. Change the Blog URL to https://www.agrofarm.cz/ and save the changes. Then clear the cache in Flatpress and it should work.

Solution 2:
Run the Flatpress Setup again and enter your https://www.agrofarm.cz/ in step 2 under URL/www.
Then clear the cache in Flatpress and it should work.

Solution 3 (quick&dirty, not recommended)
Download your settings.conf.php via FTP and change the www-entry manually in the editor to:

Code: Select all

'www' => 'https://www.agrofarm.cz/',
Again, clear the cache in Flatpress and it should work.

Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

Re: https don't show theme

Post by Lubomír Ludvík » Mon Sep 12, 2022 4:10 pm

Don´t work.

Solution 1: Blog URL is https://agrofarm.cz/

Solution 3: in settings.conf.php is:
'www' => 'https://agrofarm.cz/'

FlatPress is 1.2.beta1, it can be a problem?

User avatar
WineMan
Posts: 78
Joined: Tue Sep 01, 2020 5:03 pm

Re: https don't show theme

Post by WineMan » Tue Sep 13, 2022 2:55 am

Isn't the current stable version 1.2.1 instead of 1.2.beta1?

laborix
Posts: 92
Joined: Sat Feb 16, 2019 3:51 pm

Re: https don't show theme

Post by laborix » Tue Sep 13, 2022 3:58 pm

Lubomír Ludvík wrote: Mon Sep 12, 2022 4:10 pm...
FlatPress is 1.2.beta1, it can be a problem? ...
I installed Flatpress 1.2 beta 1 in a test enviromnet and take a look for

Code: Select all

<link media="screen" href="http:// ...
but there is no "http://", all is "https://" :?:
Ok, let's try something ...

Solution 1:
Download the current Flatpress Version, extract it local and upload only this folder:

Code: Select all

/fp-interface/themes/leggero
Do a "override all" on your webspace, no panik, it's the actual Leggero Theme. Clear the Flatpress Cache and also the Browser Cache and test with "https://www.agrofarm.cz/"

If this doesn't work, please check in your Flatpress root directory, if there is a .htaccess file. If yes, download it local and open it with a Editor. Take a look if there ist something about http/https request. It is a possible source of error.
And tell us the missing text behind the http:// in your web source, Thank you.

Please post the results here.

Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

Re: https don't show theme

Post by Lubomír Ludvík » Wed Sep 14, 2022 10:04 am

I replaced /fp-interface/themes/leggero with new version,
in root isn´t .htaccess file
no change on https://agrofarm.cz/

laborix
Posts: 92
Joined: Sat Feb 16, 2019 3:51 pm

Re: https don't show theme

Post by laborix » Wed Sep 14, 2022 4:01 pm

Lubomír Ludvík wrote: Wed Sep 14, 2022 10:04 am... no change on https://agrofarm.cz/ ...
I'm not sure what's going wrong with your installation, so I think the best way is to do a full new installation of Flatpress like the Upgrade section in the Flatpress Wiki.
See full article: https://wiki.flatpress.org/en:doc:basic:upgrade

So, please download the newest Flatpress Version 1.2.1 here:
https://www.flatpress.org/download

Next step, unpack the Flatpress 1.2.1 completly and start the Upgrade as described in the Flatpress Wiki:
https://wiki.flatpress.org/en:doc:basic:upgrade - Section "Upgrade including full backup"

Upgrade including full backup

This should be the preferred upgrade method and is suitable for any Flatpress installation. It does not matter, whether the blog resides in your webspace root directory or within a subdirectory. In addition, you have a full backup of your webspace.

1) Download your complete blog using your FTP software
2) Delete blog contents from the webspace
3) Transfer the current Flatpress version to your webspace
4) Change permissions for “fp-content” directory to 777
5) Run setup the usual way (including language selection, menus and plugins)
6) Transfer Flatpress data from your backup to your new installation

Rebuild Index in Administration Panel - Maintain
Important Note:
For security reasons, it is recommended to delete both the “Setup” directory and the file “setup.php” from your web space!

If this doesn't work, so it is possible that your current Webspace Provider doesn't support "https://".

Hope this soved your problem.

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: https don't show theme

Post by Arvid » Sat Sep 17, 2022 12:21 pm

Ahoj, could you please add

Code: Select all

{$smarty.const.BLOG_BASEURL}
somewhere to a template file of your theme (e.g. fp-interface/themes/leggero/footer.tpl) and check what is displayed when you call your web site via either HTTP and HTTPS?
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

Lubomír Ludvík
Posts: 44
Joined: Wed Feb 20, 2019 7:44 pm
Location: Rouchovany
Contact:

Re: https don't show theme

Post by Lubomír Ludvík » Sun Sep 18, 2022 8:22 pm

Arvid wrote: Sat Sep 17, 2022 12:21 pm Ahoj, could you please add

Code: Select all

{$smarty.const.BLOG_BASEURL}
I add, no change.
I try another theme from https://flatpress.info/ZIP/flatpress-1. ... mePlus.zip
and all theme has problem with https://

Code: Select all

I repair theme in /fp-content/config/settings.conf.php
'theme' => 'leggero',

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: https don't show theme

Post by Arvid » Mon Sep 19, 2022 4:44 am

You added {$smarty.const.BLOG_BASEURL} to your template, so you see your blog_baseurl at that particular place (e.g. in the blog header).
Call your blog via HTTP: The blog_baseurl you added to the template should start with "http://".
Now call your blog via HTTPS - does the blog_baseurl start with "http://" again?
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests