Error viewing several topics or posts

General information and announcements regarding the FlatPress project
Post Reply
bttr
Posts: 46
Joined: Tue Mar 22, 2022 9:20 pm
Location: Berlin, Germany
Contact:

Error viewing several topics or posts

Post by bttr » Mon Oct 24, 2022 8:10 pm

Today I noticed that I'm unable to open some topics or posts. They just show up as a blank (white) page in my Firefox browser. I now tried Chromium with a new incognito window. It shows HTTP ERROR 500.

One of these topics is Count total number of articles?.

Another one is Re: My Retro FlatPress Blogs.
Viewing the topic itself works: My Retro FlatPress Blogs, but you can't go to the second page. Blank (white) page again.
Going to the third page in this topic works though.

User avatar
Madekozu
Posts: 45
Joined: Thu Apr 21, 2022 8:41 am
Location: Hemmingen (Germany, BaWü)
Contact:

Re: Error viewing several topics or posts

Post by Madekozu » Tue Oct 25, 2022 1:28 pm

Oh, is with me also so E500

I've just tried a little bit - could it be that posts in these threads were deleted and phpbb got confused there?

viewtopic.php?t=219&start=0 <- works
viewtopic.php?t=219&start=1 <- does not work
viewtopic.php?t=219&start=2 <- does not work
viewtopic.php?t=219&start=3 <- does not work
viewtopic.php?t=219&start=4 <- does not work
viewtopic.php?t=219&start=5 <- does not work
viewtopic.php?t=219&start=6 <- does not work
viewtopic.php?t=219&start=7 <- does not work
viewtopic.php?t=219&start=8 <- does not work
viewtopic.php?t=219&start=9 <- does not work
viewtopic.php?t=219&start=10 <- does not work
viewtopic.php?t=219&start=11 <- works again

All calls that would contain 10 at the start (0-9 is displayed for 0, 1-10 for 1, etc.) do not work. Maybe that helps a little with troubleshooting.

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Error viewing several topics or posts

Post by Arvid » Thu Oct 27, 2022 7:30 pm

Hi,

thank you very much for reporting this. I simply switched from PHP 7.4 to 8.0, now it works again. Sadly, this marks the end of the Archives (that were the only reason for me to still stick with 7.4).

All the best,
Arvid
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

bttr
Posts: 46
Joined: Tue Mar 22, 2022 9:20 pm
Location: Berlin, Germany
Contact:

Re: Error viewing several topics or posts

Post by bttr » Fri Oct 28, 2022 7:19 pm

Dunno how your server is setup, but if you create a new subdomain, e.g., forum-archive.flatpress.org, you could probably select a different PHP version for that subdomain.

User avatar
Arvid
FlatPress Coder
Posts: 443
Joined: Sat Jan 26, 2019 7:40 pm
Contact:

Re: Error viewing several topics or posts

Post by Arvid » Fri Oct 28, 2022 7:23 pm

Thought about that, too - but support for PHP 7.4 will end soon anyway...
Helpful FlatPress links: Project blog 📝 - FlatPress wiki 📖 - FlatPress@Twitter 🐦 - FlatPress@Mastodon 🐘
Stay up to date with our feeds: Forum RSS feed 📜 - Project blog RSS feed 📜
Feel free to say Thank you: Donate ❤️

🔥 How to rework your themes and plugins for FlatPress 1.3 / Smarty 4 🔥

🇩🇪 Für meinen Arbeitgeber in Bochum habe ich eine Stelle zu besetzen: Junior-Systemadministrator 🇩🇪

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests