Page 1 of 1

FlatPress 1.3.1 - PHP 8.4.0 Alpha 1

Posted: Sun Jul 07, 2024 7:25 am
by laborix
FlatPress 1.3.1 Quick&Dirty Test

Test Server Environment:
Apache 2.4 with FastCGI Interface and PHP 8.4.0 Alpha 1

Code: Select all

PHP Deprecated:  Smarty_Internal_Method_GetTemplateVars::getTemplateVars(): Implicitly marking parameter $_ptr as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_method_gettemplatevars.php on line 34
PHP Deprecated:  Smarty_Internal_Method_GetTemplateVars::_getVariable(): Implicitly marking parameter $_ptr as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_method_gettemplatevars.php on line 87
PHP Deprecated:  Smarty_Internal_TemplateCompilerBase::compileTemplate(): Implicitly marking parameter $parent_compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 386
PHP Deprecated:  Smarty_Internal_TemplateCompilerBase::compileTemplateSource(): Implicitly marking parameter $parent_compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 417
PHP Deprecated:  Smarty_Internal_Runtime_CodeFrame::create(): Implicitly marking parameter $compiler as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_internal_runtime_codeframe.php on line 28
PHP Deprecated:  Smarty_Resource_Custom::populate(): Implicitly marking parameter $_template as nullable is deprecated, the explicit nullable type must be used instead in .../fp-includes/smarty-4.3.1/libs/sysplugins/smarty_resource_custom.php on line 48

Re: FlatPress 1.3.1 - PHP 8.4.0 Alpha 1

Posted: Tue Jul 09, 2024 9:01 pm
by fraenkiman
Hello Laborix,

Thank you for the quick & dirty test. That was to be expected. I have recorded it here. Smatry 4 (including Smarty 4.5.3) only supports PHP 7.1 to PHP 8.3. We will have to get used to Smarty 5 in the near future.

With best regards
Frank