Page 1 of 1

Flatpress 1.3.1 Issue - Can't edit entries

Posted: Wed Sep 03, 2025 6:42 am
by Tongara
Hello,

Bit of a strange one, which I guess I just didn't notice at the time.

Last Summer I updated my FlatPress to 1.3.1, and managed to fix pretty much every 500 Error issue, and it's been smooth sailing since then... until today, that is.

I noticed that whenever I go to edit an entry, I get a 500 error... and I have absolutely no idea why. I did check the error logs of my hosting, but it didn't really point me to much. The error can be seen below:

Code: Select all

[Tue Sep 02 07:33:31.009575 2025] [core:crit] [pid 1974669:tid 1974921] (13)Permission denied: [client 86.18.9.188:0] AH00529: /home/clockwor/public_html/unfinished/fp-plugins/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/home/clockwor/public_html/unfinished/fp-plugins/' is executable, referer: https://www.clockworkknight.com/unfinished/admin.php?p=entry
Any help on this would be great, because I've never seen anything about there being an .htaccess file in the plugins folder before, and none of my backups have ever needed such. I have also checked that the permissions of admin.entry.write.php and admin.entry.write.tpl are set correctly.

To note, writing new entries is fine, and writing/editing static pages has no problem. It's literally just editing entries that has the problem!

I understand 1.3.1 is outdated, but I am waiting to fix this issue first and then for the "automatic updater" for 1.3.1 to 1.4.1 that was spoken about back in August to release.

Thanks in advance!

Edit: Just to note, this forum seems to be getting a lot of 403 errors recently. I'm not sure what is going on, but sometimes I'm having to refresh multiple times to see anything. Just thought I should make you aware!

Re: Flatpress 1.3.1 Issue - Can't edit entries

Posted: Wed Sep 03, 2025 8:04 pm
by fraenkiman
Hello Tongara,

It is highly unlikely that this is a FlatPress bug.
The log shows a file system/ownership/permissions issue with the host.
If you manage your web space with cPanel, the answer may lie here:
https://support.cpanel.net/hc/en-us/com ... executable

...Confirm cPanel default settings: public_html as directory 755, .htaccess 644; deviations lead to AH00529.
Tongara wrote: Wed Sep 03, 2025 6:42 am Edit: Just to note, this forum seems to be getting a lot of 403 errors recently. I'm not sure what is going on, but sometimes I'm having to refresh multiple times to see anything. Just thought I should make you aware!
If I had to guess, this is probably the cause:
https://www.heise.de/news/Ueberlastungs ... 30141.html

Best regards,
Frank

Re: Flatpress 1.3.1 Issue - Can't edit entries

Posted: Wed Sep 03, 2025 9:27 pm
by fraenkiman
Another possible solution:

The current (Apache?) server configuration may assume that there is an .htaccess file there, regardless of whether there actually is one or not.
Either set the appropriate <Directory> to AllowOverride None via cPanel, or ask your host to do this for you.

Re: Flatpress 1.3.1 Issue - Can't edit entries

Posted: Thu Sep 04, 2025 5:39 am
by Tongara
fraenkiman wrote: Wed Sep 03, 2025 8:04 pm Hello Tongara,

It is highly unlikely that this is a FlatPress bug.
The log shows a file system/ownership/permissions issue with the host.
If you manage your web space with cPanel, the answer may lie here:
https://support.cpanel.net/hc/en-us/com ... executable

...Confirm cPanel default settings: public_html as directory 755, .htaccess 644; deviations lead to AH00529.
Hi there, just to note, I have permissions set correctly. It's strange, because another FlatPress 1.3.1 instance I have on the same host DOESN'T have this issue when I go to edit entries. Are we sure there is nothing that FlatPress is doing here? Just asking, of course. I know I had to edit a bunch of files before when upgrading to 1.3.1...

I also just installed an instance of the latest 1.4.1 version of FlatPress and see if that gets the 500 error... and nope! All smooth sailing there too.

One thing to note in my instance of FlatPress where it doesn't work, when I edit Static pages, I get no "preview" at the top. I'm stumped as to why this one instance which I have used for years is getting all these issues.
fraenkiman wrote: Wed Sep 03, 2025 9:27 pm Another possible solution:

The current (Apache?) server configuration may assume that there is an .htaccess file there, regardless of whether there actually is one or not.
Either set the appropriate <Directory> to AllowOverride None via cPanel, or ask your host to do this for you.
I will ask them so if we can't get this sorted on here.

I really appreciate your help!

Re: Flatpress 1.3.1 Issue - Can't edit entries

Posted: Thu Sep 04, 2025 8:23 am
by Tongara
So, a little update on this... apparently I never fixed a single line in both preview.tpl and previewstatic.tpl, and doing so has fixed this issue.

I feel very silly about this oversight. :oops:

Weird that it was throwing up .htaccess errors...

Oh well, thank you for all your help on this again!